字符串替换 (replace)

Posted cstdio1

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了字符串替换 (replace)相关的知识,希望对你有一定的参考价值。

将文本文件中指定的字符串替换成新字符串。 由于目前的OJ系统暂时不能支持用户读入文件,我们编写程序从键盘输入文件中的内容,当输入的一行为end时,表示结束。end后面有两个字符串,要求用第二个字符串替换文本中所有的第一个字符串。

输入格式:

Xi’an Institute of Posts and Telecommunications is co-designed and implemented by the People’s Government of Shaanxi Province and the Ministry of Industry and Information Technology. The Institute is located in Xi’an, a historic city in Northwest China, famous for its magnificent ancient culture.

end (表示结束)

Institute (第一个字符串,要求用第二个字符串替换)

University (第二个字符串)

输出格式:

Xi’an University of Posts and Telecommunications is co-designed and implemented by the People’s Government of Shaanxi Province and the Ministry of Industry and Information Technology.The University is located in Xi’an, a historic city in Northwest China, famous for its magnificent ancient culture.

输入样例:

Xi’an Institute of Posts and Telecommunications is co-designed and implemented by the People’s Government of Shaanxi Province and the Ministry of Industry and Information Technology.
The Institute is located in Xi’an, a historic city in Northwest China, famous for its magnificent ancient culture.
end
Institute
University

输出样例:

Xi’an University of Posts and Telecommunications is co-designed and implemented by the People’s Government of Shaanxi Province and the Ministry of Industry and Information Technology.The University is located in Xi’an, a historic city in Northwest China, famous for its magnificent ancient culture.
#include<iostream>
#include<cstring>
using namespace std;
int main()

string a,b,c,m;
getline(cin,a);
while(1)

getline(cin,m);
if(m=="end")
	break;
	
a+=‘\n‘;
a+=m;	

a+=‘\n‘;
getline(cin,b);
getline(cin,c);
int found;
found=a.find(b);
while(found!=-1)

a.replace(found,b.size(),c);
found=a.find(b,found+1);	
cout<<a; 
return 0;

  


以上是关于字符串替换 (replace)的主要内容,如果未能解决你的问题,请参考以下文章

js的replace如何全部替换目标字符串

js replace替换指定位置后面的字符串

js中怎么用replace替换字符串中的问号

Java怎么使用replace替换字符串中的某一位的字符

java replace方法

js replace替换字符串,同时替换多个方法