HDU 1159 最长公共子序列

Posted fangxiaoqi

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1159 最长公共子序列相关的知识,希望对你有一定的参考价值。

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53443    Accepted Submission(s): 24607


Problem Description
  A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
  The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

 

Sample Input
abcfbc abfcab
programming contest
abcd mnp
 
Sample Output
4
2
0

 

 

 

【题意】

  一个给定序列的子序列是一个给定序列,其中有些元素(可能没有)被省略。给定一个序列 X = <x1, x2, ..., xm> 另一个序列 Z = <z1, z2, ..., zk> 是X的子序列,如果存在严格递增序列, <i1, i2, ..., ik> 对所有 j = 1,2,…,k, xij = zj。例如,Z = <a, b, f, c> 是 X = <a, b, c, f, b, c>  的子序列,索引序列< 1,2,4,6 >。给定两个序列X和Y,问题是求X和Y的最大长度公共子序列的长度。

  序列由任意数量的空格分隔。输入数据是正确的。对于每组数据,程序在标准输出上打印从单独行开始的最大长度公共子序列的长度。

  注意:最长公共子序列 ,可以不连续。

 

【代码】

#include<bits/stdc++.h>
#define MAX 5005
using namespace std;
int f[MAX][MAX];
string s,t;
int main(){
    while(cin>>s>>t){
        for(int i=1;i<=s.length();i++)
            for(int j=1;j<=t.length();j++){
                f[i][j]=max(f[i-1][j],f[i][j-1]);
                if(s[i-1]==t[j-1])
                f[i][j]=max(f[i][j],f[i-1][j-1]+1);
       }
       cout<<f[s.length()][t.length()]<<endl;
    }
    return 0;
}

 

以上是关于HDU 1159 最长公共子序列的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1159 最长公共子序列

hdu 1159 Common Subsequence(最长公共子序列)

hdu 1159 Common Subsequence(dp 最长公共子序列问题LCS)

hdu 1159 Common Subsequence (最长公共子序列)

hdu1159Common Subsequence(最长公共子序列)

HDU 1159 Common Subsequence (动态规划最长公共子序列)