51nod 1004 n^n的末位数字

Posted 8023spz

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了51nod 1004 n^n的末位数字相关的知识,希望对你有一定的参考价值。

给出一个整数N,输出N^N(N的N次方)的十进制表示的末位数字。
 

输入

一个数N(1 <= N <= 10^9)

输出

输出N^N的末位数字

输入样例

13

输出样例

3


快速幂
代码:
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <algorithm>

using namespace std;
int n;

int main() {
    scanf("%d",&n);
    int d = 1,e = n % 10;
    while(n) {
        if(n % 2) d = (d * e) % 10;
        e = (e * e) % 10;
        n /= 2;
    }
    printf("%d",d);
    return 0;
}

 

以上是关于51nod 1004 n^n的末位数字的主要内容,如果未能解决你的问题,请参考以下文章

51nod 1004 n^n的末位数字

51Nod - 1004 n^n的末位数字

51nod 1004 n^n的末位数字快速幂

51nod1004 n^n的末位数字

51nod 1004 n^n的末位数字

51Nod 1004 n^n的末位数字(日常复习快速幂,莫名的有毒,卡mod值)