PAT 1028 List Sorting

Posted cunyusup

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT 1028 List Sorting相关的知识,希望对你有一定的参考价值。

1028 List Sorting (25 分)
 

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student‘s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID‘s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID‘s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define MAXN 500

struct node{
    string id;
    string name;
    int point;
};

bool comp1(node a,node b){
    return a.id < b.id;
}

bool comp2(node a,node b){
    if(a.name==b.name) return a.id < b.id;
    return a.name < b.name;
}

bool comp3(node a,node b){
    if(a.point==b.point) return a.id < b.id;
    return a.point < b.point;
}




int main(){
    int n,c;
    cin >> n >> c;
    node nod[n];
    for(int i=0;i < n;i++){
        char xid[10];
        char xname[10];
        int g;
        scanf("%s%s%d",xid,xname,&g);

//        cin >> xid >> xname >> g;
        nod[i].id = xid;
        nod[i].name = xname;
        nod[i].point = g;
    }

    if(c == 1){sort(nod,nod+n,comp1);}
    else if(c == 2){sort(nod,nod+n,comp2);}
    else if(c == 3){sort(nod,nod+n,comp3);}

    for(int i=0;i < n;i++){
//        cout << nod[i].id << " " << nod[i].name << " " << nod[i].point << endl;
        printf("%s %s %d\n",nod[i].id.c_str(),nod[i].name.c_str(),nod[i].point);
    }


    return 0;
}

char 我开成6和8就错了??题目给的条件不对把,还是要稍微开大一点。。

当卡string输入的时候可以用char代替输入,然后再用string等于就好了,嘿嘿

 

以上是关于PAT 1028 List Sorting的主要内容,如果未能解决你的问题,请参考以下文章

PAT Advanced 1028 List Sorting (25分)

PAT 甲级 1028 List Sorting (25 分)(排序,简单题)

PAT甲级 1028 List Sorting (25分)(cin cout 超时问题)

1028. List Sorting (25)

1028 List Sorting (25 分)

1028 List Sorting (25 分)