poj_1323 Game Prediction 贪心

Posted dawn-bin

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj_1323 Game Prediction 贪心相关的知识,希望对你有一定的参考价值。

Game Prediction
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11814   Accepted: 5701

Description

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game. 



Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game. 

Input

The input consists of several test cases. The first line of each case contains two integers m (2?20) and n (1?50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

The input is terminated by a line with two zeros. 

Output

For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game. 

Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0

Sample Output

Case 1: 2
Case 2: 4

从最大n*m 记录自己没有的牌为count, count表示能大于自己的可能输掉的情况.
如果碰到自己有的牌,count>0时消耗掉一张大于自己的牌, count=0时, 表示没有比自己大的牌 ans++;

 

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <cstring>

using namespace std;

int main()
{
    int n, m, num, max, count, ans, Case=1;
    bool data[25000];
    while(scanf("%d%d", &n, &m) && n && m)
    {
        max = n*m;
        count=0;
        ans=0;
        memset(data, 0, sizeof(data));
        for(int i=0; i<m; i++)
        {
            scanf("%d", &num);
            data[num] = true;
        }
        getchar();getchar();
        for(int i=max; i>0; i--)
        {
            if(!data[i])
                count++;
            else if(data[i])
            {
                if(count==0)
                    ans++;
                else
                    count--;
            }
        }

        printf("Case %d: %d\n", Case++, ans);
    }
    return 0;
}

 



以上是关于poj_1323 Game Prediction 贪心的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1323 Game Prediction#贪心

POJ1323 LA2521 HDU1338 ZOJ1362 Game Prediction贪心

HDU 1338 Game Prediction

POJ_1753——Flip Game(枚举)

[poj2234]Matces Game_博弈论

[poj2505]A multiplication game_博弈论