线段树的区间合并 B - LCIS
Posted echozqn
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了线段树的区间合并 B - LCIS相关的知识,希望对你有一定的参考价值。
Given n integers.
You have two operations:
U A B: replace the Ath number by B. (index counting from 0)
Q A B: output the length of the longest consecutive increasing subsequence (LCIS) in [a, b].
You have two operations:
U A B: replace the Ath number by B. (index counting from 0)
Q A B: output the length of the longest consecutive increasing subsequence (LCIS) in [a, b].
InputT in the first line, indicating the case number.
Each case starts with two integers n , m(0<n,m<=10 5).
The next line has n integers(0<=val<=10 5).
The next m lines each has an operation:
U A B(0<=A,n , 0<=B=10 5)
OR
Q A B(0<=A<=B< n).
OutputFor each Q, output the answer.Sample Input
1
10 10
7 7 3 3 5 9 9 8 1 8
Q 6 6
U 3 4
Q 0 1
Q 0 5
Q 4 7
Q 3 5
Q 0 2
Q 4 6
U 6 10
Q 0 9
Sample Output
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn = 1e5 + 100;
struct node
{
int l, r, rp, lp, len;
int max_pre, max_sub, max_last;
}tree[maxn*4];
int a[maxn];
void push_up(int id)
{
tree[id].rp = tree[id<<1|1].rp;
tree[id].lp = tree[id << 1].lp;
tree[id].max_pre = tree[id << 1].max_pre;
tree[id].max_last = tree[id << 1 | 1].max_last;
tree[id].max_sub = max(tree[id << 1].max_sub, tree[id << 1 | 1].max_sub);
if(tree[id<<1].rp<tree[id<<1|1].lp)
{
if (tree[id << 1].max_pre == tree[id << 1].len) tree[id].max_pre += tree[id << 1 | 1].max_pre;
if (tree[id << 1 | 1].max_last == tree[id << 1 | 1].len) tree[id].max_last += tree[id << 1].max_last;
tree[id].max_sub = max(tree[id].max_sub, tree[id << 1].max_last + tree[id<<1|1].max_pre);
}
}
void build(int id,int l,int r)
{
tree[id].l = l;
tree[id].r = r;
tree[id].len = r - l + 1;
if(l==r)
{
tree[id].rp = tree[id].lp = a[l];
tree[id].max_pre = tree[id].max_last = tree[id].max_sub = 1;
return;
}
int mid = (l+r) >> 1;
build(id << 1, l, mid);
build(id << 1 | 1, mid + 1, r);
push_up(id);
}
int query(int id,int x,int y)
{
int ans = 0;
if(x<=tree[id].l&&tree[id].r<=y)
{
return tree[id].max_sub;
}
int mid = (tree[id].l + tree[id].r) >> 1;
if (x <= mid) ans = max(ans, query(id << 1, x, y));
if (y > mid) ans = max(ans, query(id << 1 | 1, x, y));
if(tree[id<<1].rp<tree[id<<1|1].lp)
{
ans = max(ans, min(mid - x + 1, tree[id << 1].max_last) + min(y - mid, tree[id << 1 | 1].max_pre));
}
return ans;
}
void update(int id,int x,int z)
{
if(tree[id].l==tree[id].r&&tree[id].l==x)
{
tree[id].rp = z;
tree[id].lp = z;
return;
}
int mid = (tree[id].l + tree[id].r) >> 1;
if (x <= mid) update(id << 1, x, z);
if (x > mid) update(id << 1 | 1, x, z);
push_up(id);
}
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
int n, m;
scanf("%d%d", &n, &m);
for(int i=1;i<=n;i++)
{
scanf("%d", &a[i]);
}
build(1, 1, n);
while(m--)
{
char s[10];
int x, y;
scanf("%s %d %d", s, &x, &y);
if(s[0]==‘Q‘)
{
int ans = query(1, x+1, y+1);
printf("%d\n", ans);
}
else update(1, x+1, y);
}
}
}
以上是关于线段树的区间合并 B - LCIS的主要内容,如果未能解决你的问题,请参考以下文章