poj 2255 Tree Recovery 分治

Posted xjhz

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 2255 Tree Recovery 分治相关的知识,希望对你有一定的参考价值。

Tree Recovery

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 

D
/
/
B E
/ \
/ \
A C G
/
/
F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file. 

Output

For each test case, recover Valentine‘s binary tree and print one line containing the tree‘s postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

Source

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define ll __int64
#define mod 1000000007
#define pi (4*atan(1.0))
const int N=1e5+10,M=1e6+10,inf=1e9+10;
char a[100],b[100];
char ans[N];
void dfs(char *a,char *b,char *c,int len)
{
    if(len<=0)
    return;
    int n=strlen(b),pos=1;
    for(int i=0;i<n;i++)
    {
        if(b[i]==a[0])
        {
            pos=i;
            break;
        }
    }
    int l=pos;
    int r=len-pos-1;
    dfs(a+1,b,c,l);
    dfs(a+l+1,b+l+1,c+l,r);
    c[len-1]=a[0];
}
int main()
{
    int x,y,z,i,t;
    while(~scanf("%s%s",a,b))
    {
        x=strlen(a);
        dfs(a,b,ans,x);
        ans[x]=0;
        cout<<ans<<endl;
    }
    return 0;
}

 

以上是关于poj 2255 Tree Recovery 分治的主要内容,如果未能解决你的问题,请参考以下文章

POJ 2255 Tree Recovery

POJ-2255-Tree Recovery-求后序

POJ 2255 Tree Recovery

Tree Recovery POJ - 2255

POJ 2255 -- Tree Recovery

POJ - 2255 - Tree Recovery = 二叉树遍历