PAT 1104 Sum of Number Segments

Posted cunyusup

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT 1104 Sum of Number Segments相关的知识,希望对你有一定的参考价值。

1104 Sum of Number Segments (20 分)
 

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 1. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;


int main(){
    int n;cin >> n;
    double sum = 0.0;
    for(int i=1;i <= n;i++){
        double x;cin >> x;

        sum+=i*(n+1-i)*x;
    }
    printf("%.2f",sum);

    return 0;
}

x放右面就过不了几个点,x放左边就能过了

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;


int main(){
    int n;cin >> n;
    double sum = 0.0;
    for(int i=1;i <= n;i++){
        double x;cin >> x;

        sum+=x*i*(n+1-i);
    }
    printf("%.2f",sum);

    return 0;
}

对拍了半小时也没啥不同,这个bug先欠着,以后记着把double放左边先乘

 

以上是关于PAT 1104 Sum of Number Segments的主要内容,如果未能解决你的问题,请参考以下文章

PAT甲级——1104 Sum of Number Segments (数学规律自动转型)

1104. Sum of Number Segments (20)数学题——PAT (Advanced Level) Practise

PAT (Advanced Level) 1104. Sum of Number Segments (20)

1104. Sum of Number Segments (20)数学题——PAT (Advanced Level) Practise

1104. Sum of Number Segments (20)数学题——PAT (Advanced Level) Practise

PAT 甲级 1104 Sum of Number Segments (20分)(有坑,int *int 可能会溢出)