poj1681 Network

Posted clb123

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj1681 Network相关的知识,希望对你有一定的参考价值。

题目链接 https://cn.vjudge.net/problem/17712/origin
Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs). 
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections. 
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied. 

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 10 6. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3

思路:最小生成树应用,kruskal算法,只要将用过的权值标记出来(例如标记为-1),最后再将其输出就行。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
const int N = 1e6+10;
int f[N];
struct edge{
	int u;
	int v;
	int cap; 
}e[N];
bool cmp(edge x, edge y){
	return x.cap < y.cap;
}
int find(int x){
	if(x != f[x]){
		f[x] = find(f[x]);
	}
	return f[x];
}
int merge(int u,int v){
	int t1 = find(f[u]);
	int t2 = find(f[v]);
	if(t1 != t2){
		f[t2] = t1;
		return 1;
	}
	return 0;
}
int main()
{
	int n,m,i,j;
	scanf("%d%d",&n,&m);
	for(i = 0; i <= n; i++){
		f[i] = i;
	}
	int max = 0,x = 0;
	for(i = 1; i <= m; i++){
		scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].cap);
	}
	sort(e+1,e+m+1,cmp);
	for(i = 1; i <= m; i++){
		if(merge(e[i].u,e[i].v) == 1){
			if(e[i].cap > max){
				max = e[i].cap;
			}
			e[i].cap = -1; //标记符合条件的边
			x++;
			if(x == n-1){
				break;
			}
		}
	}
	printf("%d\n",max);
	printf("%d\n",n-1);
	for(i = 1; i <= m; i++){
		if(e[i].cap == -1){   //输出符合条件的值
			printf("%d %d\n",e[i].u,e[i].v);
		}
	}
	return 0;
}

  



3 4

以上是关于poj1681 Network的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1681---Painter's Problem(高斯消元)

POJ 1681 Painter's Problem 高斯消元 二进制枚举

POJ 1681 Painter's Problem 高斯消元

POJ 1681 Painter's Problem(高斯消元)

poj 1681 Painter&#39;s Problem(高斯消元)

(模板)poj1681 高斯消元法求异或方程组(无解唯一解多解)