POJ-1847 Tram

Posted 季末Despaire

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ-1847 Tram相关的知识,希望对你有一定的参考价值。

Tram

Time Limit: 1000MS   Memory Limit: 30000K

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch. 

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually. 

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N. 

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0

题解
很简单的最短路问题,套版就行,建好图就行了,这里用未优化的Dijkstra就行了
代码
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int maxn = 100+7;
const int inf=0x3f3f3f3f;

//*****************************************
//Dijkstra-数组实现O(n^2)
//单源最短路
//lowcost[]-----从点beg到其他点的距离
//*****************************************
bool vis[maxn];
void Dijkstra(int cost[][maxn],int lowcost[maxn],int n,int beg)
{
    int minc;
    int i,j,w;
    memset(vis,false,sizeof(vis));
    vis[beg]=true;
    for(i=1;i<=n;i++) lowcost[i]=cost[beg][i];
    lowcost[beg]=0;
    for(i=1;i<=n;i++){
        minc=inf;
        for(j=1;j<=n;j++){
            if(!vis[j]&&lowcost[j]<minc){
                minc=lowcost[j];
                w=j;
            }
        }
        if(minc>=inf) break;
        vis[w]=true;
        for(j=1;j<=n;j++)
            if(!vis[j]&&lowcost[w]+cost[w][j]<lowcost[j])
            lowcost[j]=lowcost[w]+cost[w][j];
    }
}

int cost[maxn][maxn];
int dist[maxn];
int main()
{
    int n,A,B;
    int k,t;
    while(scanf("%d%d%d",&n,&A,&B)!=EOF){
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                if(i==j) cost[i][j]=0;
                else cost[i][j]=inf;
            }
        }
        for(int i=1;i<=n;i++){
            scanf("%d",&k);
            for(int j=0;j<k;j++){
                scanf("%d",&t);
                if(j==0) cost[i][t]=0;
                else cost[i][t]=1;
            }
        }
        Dijkstra(cost,dist,n,A);
        if(dist[B]>=inf) printf("-1\n");
        else printf("%d\n",dist[B]);
    }
    return 0;
}

 

 

以上是关于POJ-1847 Tram的主要内容,如果未能解决你的问题,请参考以下文章

POJ-1847 Tram

Tram---poj1847(简单最短路)

POJ 1847

poj1847 Tram(最短路dijkstra)

POJ-1847 最短路裸题,Floyd, Bellman, Dijkstra, Spfa

poj 1847 最短路简单题,dijkstra