poj3372

Posted 神犇(shenben)

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj3372相关的知识,希望对你有一定的参考价值。

Candy Distribution
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5868   Accepted: 3274

Description

N children standing in circle who are numbered 1 through N clockwise are waiting their candies. Their teacher distributes the candies by in the following way:

First the teacher gives child No.1 and No.2 a candy each. Then he walks clockwise along the circle, skipping one child (child No.3) and giving the next one (child No.4) a candy. And then he goes on his walk, skipping two children (child No.5 and No.6) and giving the next one (child No.7) a candy. And so on.

Now you have to tell the teacher whether all the children will get at least one candy?

Input

The input consists of several data sets, each containing a positive integer N (2 ≤ N ≤ 1,000,000,000).

Output

For each data set the output should be either "YES" or "NO".

Sample Input

2
3 
4

Sample Output

YES
NO
YES

Source

这是一个复杂的数学问题,但是可以通过小数据猜测出来,最后发现只要是2的幂就行,否则不行
#include<cstdio>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {
        while(n%2==0)
            n/= 2;
        if(n==1)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

以上是关于poj3372的主要内容,如果未能解决你的问题,请参考以下文章

[POJ3372]Candy Distribution

第一次训练题解

POJ 1984 - Navigation Nightmare - [带权并查集]

P3372 模板线段树 1

P3372 模板线段树 1

BZOJ 1008 越狱 题解 裸快速幂