find your present

Posted ly_rabbit

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了find your present相关的知识,希望对你有一定的参考价值。

Description
In the new year party, everybody will get a "special present".Now its your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your presents card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.


Input
The input file will consist of several cases. 
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.


Output
For each case, output an integer in a line, which is the card number of your present.


Sample Input 5
1 1 3 2 2
3
1 2 1
0


Sample Output
3
2


#include<stdio.h>
void main()
{
    long n,x,y,i;
    while(scanf("%ld",&n)==1 && n)
    {
        x=0;
        for(i=0;i<n;i++)
        {
            scanf("%ld",&y);
            x^=y;
        }
        printf("%ld\n",x);
    }

}

 

以上是关于find your present的主要内容,如果未能解决你的问题,请参考以下文章

HDU 2095 find your present

7K - find your present

hdu 1563 Find your present!

HDU-2095-find your present -位或/STL(set)

find your present (感叹一下位运算的神奇)

HDU 2095 find your present 异或