CodeVS1983等式问题

Posted いとう かいじ

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了CodeVS1983等式问题相关的知识,希望对你有一定的参考价值。

Description

有一个未完成的等式:1 2 3 4 5 6 7 8 9=N 空格(1前面没有空格)内可以填入+,-,也可以不填。 编程找出输入某个整数 N 后使等式成立的所有方案的总数。保证有解。

Input

输入一个数N。

Output

输出一个数。所有的方案数。

Sample Input

108

Sample Output

15

题解

搜索每一位填什么符号,需要注意的一点是,[1*2+3*4-5,要注意运算顺序],所以要开个变量存一个+/-到下一个+/-中间的部分。下边代码中的z就是这个作用,t存符号。

还需要注意,下边的dfs(1,0,1,1)不能写成dfs(1,1,0,0),因为一开始这个1相当于从0加上的(因为1前边不能加符号)

#include<iostream>
#include<cstdio>
using namespace std;
int n,ANS;
void dfs(int step,int ans,int z,int t)
{
    if (step == 9 && z)
        ans += z*t;
    if (step == 9 && ans == n) ANS++;
    if (step == 9) return;
    dfs(step+1,ans+z*t,step+1,1);
    dfs(step+1,ans+z*t,step+1,-1);
    dfs(step+1,ans,z*10+step+1,t);
}
int main()
{
    scanf("%d",&n);
    dfs(1,0,1,1);
    printf("%d",ANS);
}

 

以上是关于CodeVS1983等式问题的主要内容,如果未能解决你的问题,请参考以下文章

codevs 2884 字符等式

1168 火柴棒等式

NOIP 车站分级 (luogu 1983 & codevs 3294 & vijos 1851) - 拓扑排序 - bitset

codevs 3286 火柴排队

codevs 1029 遍历问题

AtCoder1983 [AGC001E] BBQ Hard