[Uva] Tex Quates (272)

Posted 柏林没有墙

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了[Uva] Tex Quates (272)相关的知识,希望对你有一定的参考价值。

 

UVA - 272
Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

TeX is a typesetting language developed by Donald Knuth. It takes source text together with a few typesetting instructions and produces, one hopes, a beautiful document. Beautiful documents use `` and " to delimit quotations, rather than the mundane " which is what is provided by most keyboards. Keyboards typically do not have an oriented double-quote, but they do have a left-single-quote ` and a right-single-quote . Check your keyboard now to locate the left-single-quote key ` (sometimes called the ``backquote key") and the right-single-quote key (sometimes called the ``apostrophe" or just ``quote"). Be careful not to confuse the left-single-quote ` with the ``backslash" key \TeX lets the user type two left-single-quotes `` to create a left-double-quote `` and two right-single-quotes ‘‘ to create a right-double-quote ‘‘. Most typists, however, are accustomed to delimiting their quotations with the un-oriented double-quote ".

If the source contained

"To be or not to be," quoth the bard, "that is the question."

then the typeset document produced by TeX would not contain the desired form:

``To be or not to be," quoth the bard, ``that is the question."

In order to produce the desired form, the source file must contain the sequence:

``To be or not to be,‘‘ quoth the bard, ``that is the question.‘‘

You are to write a program which converts text containing double-quote (") characters into text that is identical except that double-quotes have been replaced by the two-character sequences required by TeX for delimiting quotations with oriented double-quotes. The double-quote (") characters should be replaced appropriately by either `` if the " opens a quotation and by ‘‘ if the " closes a quotation. Notice that the question of nested quotations does not arise: The first " must be replaced by ``, the next by ‘‘, the next by ``, the next by ‘‘, the next by``, the next by ‘‘, and so on.

Input

Input will consist of several lines of text containing an even number of double-quote (") characters. Input is ended with an end-of-file character.

Output

The text must be output exactly as it was input except that:

  • the first " in each pair is replaced by two ` characters: `` and
  • the second " in each pair is replaced by two  characters: ‘‘.

Sample Input

"To be or not to be," quoth the Bard, "that
is the question".
The programming contestant replied: "I must disagree.
To `C‘ or not to `C‘, that is The Question!"

Sample Output

``To be or not to be,‘‘ quoth the Bard, ``that
is the question‘‘.
The programming contestant replied: ``I must disagree.
To `C‘ or not to `C‘, that is The Question!‘‘

地址:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=19396

ac代码:

#include <cstdio>
using namespace std;
int main(){
	int c;
	bool flag = 1;
	while(scanf("%c", &c) != EOF)
		if (c == ‘"‘) {printf("%s", flag ? "``":"‘‘"); flag = !flag;}
		else printf("%c", c);
	return 0;
}

题目比代码长n倍典型范例 :)

以上是关于[Uva] Tex Quates (272)的主要内容,如果未能解决你的问题,请参考以下文章

UVa 272——TeX Quotes

UVA272 TeX括号(TEX Quotes )

TEX Quotes UVA - 272字符串

UVA 272 - TEX Quotes

UVA 272 TEX Quotes 题解

题解 UVA272 TEX Quotes