hdu 1250(大整数)

Posted AC菜鸟机

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 1250(大整数)相关的知识,希望对你有一定的参考价值。

Hat‘s Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10430    Accepted Submission(s): 3447


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

 

Input
Each line will contain an integers. Process to end of file.
 

 

Output
For each case, output the result in a line.
 

 

Sample Input
100
 

 

Sample Output
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 
2005位的数大概在7100左右
import java.math.BigInteger;
import java.util.Scanner;


 
public class Main {
    
    public static void main(String[] args) {
        BigInteger [] b = new BigInteger[7200];
        b[1]=b[2]=b[3]=b[4]= BigInteger.valueOf(1);
        int len = 0;
        for(int i=5;i<7200;i++){
            b[i] = b[i-1].add(b[i-2]).add(b[i-3]).add(b[i-4]);
        }
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n = sc.nextInt();
            System.out.println(b[n]);
        }
    }
}

 

以上是关于hdu 1250(大整数)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1250 Hat's Fibonacci(大数相加)

HDU1250大数+斐波那契数列

HDU1250 Hat‘s Fibonacci (大数相加)(Java题解)

HDOJ/HDU 1250 Hat's Fibonacci(大数~斐波拉契)

HDU 1250 Hat's Fibonacci (递推大数加法string)

hdu1002 大整数计算