POJ3267 The Cow Lexicon(DP+删词)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ3267 The Cow Lexicon(DP+删词)相关的知识,希望对你有一定的参考价值。

The Cow Lexicon
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9041   Accepted: 4293

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters ‘a‘..‘z‘. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range ‘a‘..‘z‘) of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L
Line 2: L characters (followed by a newline, of course): the received message
Lines 3..W+2: The cows‘ dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source

dp[i]表示message从i位置开始需要删除几个字母

dp[i] = dp[i + 1] + 1 // 表示它在i位置并不匹配,删除i位置的字母,

dp[i] = min(dp[i],dp[i + len + t] + t) //对于长度为len的单词,从i开始需要删除t个字母才能完全匹配,i+len+t表示匹配后的下一个,dp[i+len+t]就是匹配成功下一个位置的需要删除的字母数

技术分享
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
char dic[605][50];
char mess[300 + 10];
int w,l,dp[605];
int DP(int x, int len, int y)
{
    int j = 1, tot = 0;
    while(x <= l)
    {
        if(mess[x] == dic[y][j])
            j++;
        else
            tot++;
        if(j == len + 1) // j==len的时候还没结束,还要匹配len位置,len是最后一个
            return tot;
        x++;
    }
    return -1;
}
int main()
{
    while(scanf("%d%d", &w, &l) != EOF)
    {
        scanf("%s", mess + 1);
        for(int i = 1; i <= w; i++)
        {
            scanf("%s", dic[i] + 1);
        }
        memset(dp, 0, sizeof(dp));
        for(int i = l; i > 0; i--)
        {
            dp[i] = dp[i + 1] + 1;
            for(int j = 1; j <= w; j++)
            {
                int len = strlen(dic[j] + 1);
                int t = DP(i, len, j);
                if(t != -1)
                {
                    dp[i] = min(dp[i], dp[i + len + t] + t);
                }
            }
        }
        printf("%d\n", dp[1]);
    }
    return 0;
}
View Code

 

 

以上是关于POJ3267 The Cow Lexicon(DP+删词)的主要内容,如果未能解决你的问题,请参考以下文章

poj 3267 The Cow Lexicon (动态规划)

POJ 3267 The Cow Lexicon

poj3267--The Cow Lexicon(dp:字符串组合)

POJ - 3267 The Cow Lexicon(动态规划)

POJ #3267 The Cow Lexicon 型如" E[j] = opt{D+w(i,j)} "的简单DP 区间DP

The Cow Lexicon DP