poj 3150Cellular Automaton 矩阵

Posted ALPS233

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 3150Cellular Automaton 矩阵相关的知识,希望对你有一定的参考价值。

题目http://poj.org/problem?id=3150

Cellular Automaton 矩阵乘法+二分

Cellular Automaton

Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 3544 Accepted: 1428
Case Time Limit: 2000MS

Description

A cellular automaton is a collection of cells on a grid of specified shape that evolves through a number of discrete time steps according to a set of rules that describe the new state of a cell based on the states of neighboring cells. The order of the cellular automaton is the number of cells it contains. Cells of the automaton of order n are numbered from 1 to n.

The order of the cell is the number of different values it may contain. Usually, values of a cell of order m are considered to be integer numbers from 0 to m ? 1.

One of the most fundamental properties of a cellular automaton is the type of grid on which it is computed. In this problem we examine the special kind of cellular automaton — circular cellular automaton of order n with cells of order m. We will denote such kind of cellular automaton as n,m-automaton.

A distance between cells i and j in n,m-automaton is defined as min(|i ? j|, n ? |i ? j|). A d-environment of a cell is the set of cells at a distance not greater than d.

On each d-step values of all cells are simultaneously replaced by new values. The new value of cell i after d-step is computed as a sum of values of cells belonging to the d-enviroment of the cell i modulo m.

The following picture shows 1-step of the 5,3-automaton.

The problem is to calculate the state of the n,m-automaton after k d-steps.

Input

The first line of the input file contains four integer numbers n, m, d, and k (1 ≤ n ≤ 500, 1 ≤ m ≤ 1 000 000, 0 ≤ d < n?2 , 1 ≤ k ≤ 10 000 000). The second line contains n integer numbers from 0 to m ? 1 — initial values of the automaton’s cells.

Output

Output the values of the n,m-automaton’s cells after k d-steps.

Sample Input
sample input #1
5 3 1 1
1 2 2 1 2

sample input #2
5 3 1 10
1 2 2 1 2

Sample Output
sample output #1
2 2 2 2 1

sample output #2
2 0 0 2 2

题意
一个环上有n个数,定义一种操作将它和它距离小于d的数加和再模m。每次操作刷新所有数。问k次之后都将变成什么数?

思路
很容易想到构造01矩阵,ksm求解,n太大的一点优化:发现矩阵有规律

1100001
1110000
0111000
.。。。。
只需要存第一行就行了,乘法计算如下

 for(int i=0;i<n;i++)
      for(int j=0;j<n;j++)
      c[i]+=a[j]*b[i>=j?(i-j):(n+i-j)];

代码

#include<iostream>
#include<stdio.h>
using namespace std;
int n,m,d,k;
long long init[505],tmp[505];
void mul(long long a[],long long b[])
{
      long long c[505];
      for(int i=0;i<n;i++)
      c[i]=0;
      for(int i=0;i<n;i++)
      for(int j=0;j<n;j++)
      c[i]+=a[j]*b[i>=j?(i-j):(n+i-j)];
      for(int i=0;i<n;i++)
      b[i]=c[i]%m;                     
}
int main()
{
    int i,j;
    scanf("%d%d%d%d",&n,&m,&d,&k);
    for(i=0;i<n;++i)scanf("%lld",&init[i]);
    for(tmp[0]=i=1;i<=d;++i)tmp[i]=tmp[n-i]=1;
    while(k)
    {
            if(k&1)
            mul(tmp,init);
            k>>=1;
            mul(tmp,tmp);

    }
    for(i=0;i<n;i++)
    printf("%lld ",init[i]);
    printf("\n");
}

以上是关于poj 3150Cellular Automaton 矩阵的主要内容,如果未能解决你的问题,请参考以下文章

POJ3150—Cellular Automaton(循环矩阵)

UVA620 Cellular Structure文本处理

在 iOS 中通过 Cellular 进行跟踪时获取错误坐标

UVA 1386 Cellular Automaton

457 - Linear Cellular Automata问题求解

UVa 620 Cellular Structure(DP)