poj 2081 Recaman's Sequence (dp)

Posted kk_kk

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 2081 Recaman's Sequence (dp)相关的知识,希望对你有一定的参考价值。

Recaman‘s Sequence
Time Limit: 3000MS   Memory Limit: 60000K
Total Submissions: 22566   Accepted: 9697

Description

The Recaman‘s sequence is defined by a0 = 0 ; for m > 0, am = am−1 − m if the rsulting am is positive and not already in the sequence, otherwise am = am−1 + m. 
The first few numbers in the Recaman‘s Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ... 
Given k, your task is to calculate ak.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. 
The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing ak to the output.

Sample Input

7
10000
-1

Sample Output

20
18658

 

Java AC 代码

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        
        Scanner sc = new Scanner(System.in);
        int n = 0;
        int[] result;
        boolean[] marked = new boolean[10000000];
        while((n = sc.nextInt()) != -1) {
            result = new int[n + 1];
            for(int i = 1; i < n + 1; i++) {
                int a = result[i - 1] - i;
                if(a > 0 && !marked[a]) {
                    result[i] = a;
                    marked[a] = true;
                }
                else {
                    result[i] = a + 2 * i;
                    marked[a + 2 * i] = true;
                }
            }
            System.out.println(result[n]);
            for(int i = 0; i < 10000000; i++ )
                marked[i] = false;
         }
    }
}

 

以上是关于poj 2081 Recaman's Sequence (dp)的主要内容,如果未能解决你的问题,请参考以下文章

poj 3207 Ikki's Story IV - Panda's Trick 2-SAT

sql BIT / IAM-2081 - sp2CES_ALU_ObtenerInfoInscripVigente - Se agrega para obtener la oferta edu

hdoj:2081

hdu 2081

python 类实例化

POJ 3069 Saruman's Army