ACM--过沼泽--模拟--HDOJ 5477--A Sweet Journey

Posted 学霸的一天

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了ACM--过沼泽--模拟--HDOJ 5477--A Sweet Journey相关的知识,希望对你有一定的参考价值。


HDOJ题目地址:传送门

A Sweet Journey

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 759    Accepted Submission(s): 397


Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice) 

技术分享
 

Input
In the first line there is an integer t (1t50), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers: Li,Ri, which represents the interval [Li,Ri] is swamp.
1n100,1L105,1A10,1B101Li<RiL.
Make sure intervals are not overlapped which means Ri<Li+1 for each i (1i<n).
Others are all flats except the swamps.
 

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
 

Sample Input
1 2 2 2 5 1 2 3 4
 

Sample Output
Case #1: 0

题意:一个人去旅行,路上有沼泽和平路,当走平路是增加a点体力,当走沼泽时消耗b点体力,求最开始最少要携带多少点体力

#include<iostream>
#include<stdio.h>
#include<memory.h>
#include<algorithm>
using namespace std;
struct Node{
   int begin;
   int end;
   int chazhi;
}zhaoze[101];
bool cmp(Node a,Node b){
   if(a.begin<b.begin)
	   return true;
   return false;
}
int main(){
  int n,m,i,a,b,l,kaishi,jieshu,result,temp,index=1;
  cin>>n;
  while(n--){
      cin>>m>>a>>b>>l;
	  for(i=0;i<m;i++){
	     cin>>zhaoze[i].begin>>zhaoze[i].end;
		 zhaoze[i].chazhi=zhaoze[i].end-zhaoze[i].begin;
	  }
	  sort(zhaoze,zhaoze+m,cmp);
	  result=0;
	  temp=0;
	  kaishi=0;
	  jieshu=0;
	  for(i=0;i<m;i++){
	     temp=temp+(zhaoze[i].begin-jieshu)*b-zhaoze[i].chazhi*a;
		 jieshu=zhaoze[i].end;
		 if(result>temp){
		   result=temp;
		 }
	  }
	  temp+=(l-jieshu)*b;
	  if(result>temp){
		   result=temp;
	  }
	  if(result<0){
	       printf("Case #%d: %d\n",index,-result);
	  }else{
	      printf("Case #%d: 0\n",index);
	  }
	  index++;
  }
}























以上是关于ACM--过沼泽--模拟--HDOJ 5477--A Sweet Journey的主要内容,如果未能解决你的问题,请参考以下文章

[HDOJ4782]Beautiful Soup(模拟)

[HDOJ6144] Arithmetic of Bomb(模拟)

HDU5477(模拟)

ACM--数学--HDOJ 2086--A1 = ?

HDOJ6269解题报告

ACM--DFS--最大碉堡数--HDOJ 1045--Fire Net