hdu 1787(欧拉函数)

Posted AC菜鸟机

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 1787(欧拉函数)相关的知识,希望对你有一定的参考价值。

GCD Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2874    Accepted Submission(s): 1240


Problem Description
Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a "Big Cattle".
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem:
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!
 

 

Input
Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.
 

 

Output
For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.
 

 

Sample Input
2 4 0
 

 

Sample Output
0 1
 水题一枚
#include <stdio.h>
#include <string.h>
using namespace std;
typedef long long LL;
LL phi(LL x)
{
    LL ans=x;
    for(LL i=2; i*i<=x; i++)
        if(x%i==0)
        {
            ans=ans/i*(i-1);
            while(x%i==0) x/=i;
        }
    if(x>1)
        ans=ans/x*(x-1);
    return ans;
}

int main(){
    LL n;
    while(scanf("%lld",&n)!=EOF,n){
        printf("%lld\n",n-phi(n)-1);
    }
}

 

以上是关于hdu 1787(欧拉函数)的主要内容,如果未能解决你的问题,请参考以下文章

HDOJ 1787 GCD Again(欧拉函数)

HDU 2588 GCD(欧拉函数)

hdu 6390 欧拉函数+容斥(莫比乌斯函数) GuGuFishtion

HDU 1286 找新朋友 (欧拉phi函数打表)

hdu 2824(欧拉函数)

POJ 2478 欧拉函数(欧拉筛法) HDU 1576 逆元求法