poj 2503 查字典

Posted |瑾诺学长|

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 2503 查字典相关的知识,希望对你有一定的参考价值。

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

其实用cin输入输出也可以
map<T,T>dd;
以及gets(a)与sscanf(a,"%s",str)配合用法;
a为char a[45];
#include<cstdio>
#include<string>
#include<iostream>
#include<map>
using namespace std;

int main()
{    map<string,string>dic;
    char a[11],b[11];
    int i=0;
 char str[21];
    while(gets(str))
    {
      if(str[0]==\0){break;}
      sscanf(str,"%s %s",a,b);
     dic[b]=a;
    }
    char c[11];
 string qq;
    while(scanf("%s",c)!=EOF)
        {
             string s=c;
           qq=dic[s];
           if(qq.length()==0)cout<<"eh"<<endl;
           else cout<<qq<<endl;

        }

    return 0;
}

 

以上是关于poj 2503 查字典的主要内容,如果未能解决你的问题,请参考以下文章

POJ - 2503

poj 2503 哈希 Map 字典树

poj 2503 Babelfish(字典树或着STL)

POJ2503 Babelfish

POJ-2503 Babelfish---map或者hash

POJ 2503 Babelfish