ZOJ 1709 Oil Deposits(dfs,连通块个数)

Posted 若有恒,何必三更起五更眠;最无益,莫过一日曝十日寒。

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了ZOJ 1709 Oil Deposits(dfs,连通块个数)相关的知识,希望对你有一定的参考价值。

Oil Deposits

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.


Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.


Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.


Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0


Sample Output

0
1
2
2


Source: Mid-Central USA 1997

 

分析:

dfs水题,问你@连通块的个数

@可以向8个方向扩展

和油田问题属于同一类问题

 传送门(点我)

code:

#include<bits/stdc++.h>
using namespace std;
#define max_v 105
int n,m;
char a[max_v][max_v];
int used[max_v][max_v];
int dir[8][2]={{0,1},{0,-1},{1,0},{-1,0},{1,1},{1,-1},{-1,1},{-1,-1}};
void dfs(int x,int y,int z)
{
    if(x<0||x>=n||y<0||y>=m)
        return ;
    if(used[x][y]>0||a[x][y]!=@)
        return ;
    used[x][y]=z;
    for(int i=0;i<8;i++)
        dfs(x+dir[i][0],y+dir[i][1],z);
}
int main()
{
    while(cin>>n>>m)
    {
        if(m==0&&n==0)
            break;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
               cin>>a[i][j];
            }
        }
        memset(used,0,sizeof(used));
        int c=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(used[i][j]==0&&a[i][j]==@)
                    dfs(i,j,++c);
            }
        }
        printf("%d\n",c);
    }
}

 

以上是关于ZOJ 1709 Oil Deposits(dfs,连通块个数)的主要内容,如果未能解决你的问题,请参考以下文章

Oil Deposits (DFS)

HDU 1241Oil Deposits (DFS)

Oil Deposits hdu-1241 DFS

[VJ][dfs][八连通]Oil Deposits

poj 1562 Oil Deposits(dfs)

[POJ] 1562 Oil Deposits (DFS)