HDOJ/HDU 1256 ???8(????????????~??????)
Posted
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDOJ/HDU 1256 ???8(????????????~??????)相关的知识,希望对你有一定的参考价值。
?????????
Problem Description
??????8?????????,?????????,??????????????????,????????????,????????????,????????????,???,???.
Input
?????????????????????????????????N,???????????????N?????????.
?????????????????????????????????????????????,??????????????????,??????(>=5)????????????.
Output
??????????????????????????????,??????????????????????????????6?????????1????????????.???????????????5?????????6???,??????????????????1?????????2.?????????????????????????????????,??????????????????????????????,??????????????????????????????.
???????????????8???????????????,??????????????????????????????.
Sample Input
2
A 7
B 8
Sample Output
AA
AA AA
AA AA
AA
AA AA
AA AA
AA
BBB
BB BB
BB BB
BBB
BB BB
BB BB
BB BB
BBB
????????????????????????????????????
import java.util.Scanner;
public class Main{
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int t = sc.nextInt();
int f=0;
while (t-- > 0) {
String s = sc.next();
int n = sc.nextInt();
if (f!=0) {
System.out.println();
}
int m = (int) n / 6 + 1;
// System.out.println(m);//m+2
int h = n - 3;
h = h / 2 + 1;
int p=h;
if(n%2!=0){
h--;
}
for (int i = 0; i < n; i++) {
if (i == 0 || i == n - 1 || i == p) {
for (int k = 0; k < m + h; k++) {
if (k < m) {
System.out.print(" ");
} else {
System.out.print(s);
}
}
System.out.println();
} else {
for (int k = 0; k < 2 * m + h; k++) {
if (k < m || k >= m + h) {
System.out.print(s);
} else {
System.out.print(" ");
}
}
System.out.println();
}
}
f=1;
}
}
}
以上是关于HDOJ/HDU 1256 ???8(????????????~??????)的主要内容,如果未能解决你的问题,请参考以下文章
HDOJ/HDU 2163 Palindromes(判断回文串~)
HDOJ/HDU 1321 Reverse Text(倒序输出~)
HDOJ/HDU 1113 Word Amalgamation(字典顺序~Map)