质因数分解

Posted zhuohome

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了质因数分解相关的知识,希望对你有一定的参考价值。

Description:

 输入一个正整数,将它分解为质因数(质数即素数)。例如,输入90,输出90=2*3*3*5。

 Input:

 90

 Output:

 90=2*3*3*5

 Sample Input:

20

Sample Output:
  20=2*2*5
代码:
#include <stdio.h>

void main()
{
	int i,n;
	scanf("%d",&n);
	printf("%d=",n);
	for(i=2;i<n;i++)
	{
		while(n%i==0)
		{
			n=n/i;
			printf("%d*",i);
		}
	}
	printf("%d",n);
}

  

 

以上是关于质因数分解的主要内容,如果未能解决你的问题,请参考以下文章

质因数分解

质因数分解

分解质因数

C语言,分解质因数

C语言,质因数分解

java 分解质因数 基础增强