1148 Werewolf - Simple Version (20分)

Posted littlepage

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1148 Werewolf - Simple Version (20分)相关的知识,希望对你有一定的参考价值。

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5). Then N lines follow and the i-th line gives the statement of the i-th player (1), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences [ and [, if there exists 0 such that [ (ik) and [, then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4
 

Sample Output 1:

1 4
 

Sample Input 2:

6
+6
+3
+1
-5
-2
+4
 

Sample Output 2 (the solution is not unique):

1 5
 

Sample Input 3:

5
-2
-3
-4
-5
-1
 

Sample Output 3:

No Solution

狼人杀,已知狼人和好人,狼人有2个,有1个说了假话,其他都是好人,有1个说了假话。

我们要求出谁是狼人。

我们进行2次遍历,进行默认,i,j是狼人,查看总共的假话人数是否为2,以及查看狼人是否有一个说了假话。

#include <iostream>
using namespace std;
int main() {
    int N, arr[200], judge[200];
    cin >> N;
    for(int i = 1; i <= N; i++)
        cin >> arr[i];
    for(int i = 1; i <= N - 1; i++) {
        for(int j = i + 1; j <= N; j++) {
            int cnt = 0, wolfcnt = 0;
            fill(judge + 1, judge + N + 1, 1); // 1代表好人
            judge[i] = judge[j] = -1; // -1代表狼
            for(int k = 1; k <= N; k++) 
                if(judge[abs(arr[k])] * arr[k] < 0) cnt++; 
            
            if(judge[abs(arr[i])] * arr[i] < 0) wolfcnt++;
            if(judge[abs(arr[j])] * arr[j] < 0) wolfcnt++;
            if(cnt == 2 && wolfcnt == 1) {
                cout << i << " " << j << endl;
                exit(0);
            }
        }
    }
    cout << "No Solution" << endl;
    return 0;
}

 

以上是关于1148 Werewolf - Simple Version (20分)的主要内容,如果未能解决你的问题,请参考以下文章

1148 Werewolf - Simple Version (20分)

1148 Werewolf - Simple Version (20 分)

1148 Werewolf - Simple Version

1148 Werewolf - Simple Version (20 分)难度: 一般 / 思维 枚举

PAT(甲级)2018年秋季考试 7-1 Werewolf - Simple Version

PAT 2018 秋