PAT Advanced 1038 Recover the Smallest Number (30分)

Posted littlepage

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT Advanced 1038 Recover the Smallest Number (30分)相关的知识,希望对你有一定的参考价值。

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87
 

Sample Output:

22932132143287

这道题考察贪心和stl,我们通过比较两个串的组合大小,即可解决

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
bool cmp(string s1, string s2) {
    return s1 + s2 < s2 + s1;
}
int main(){
    int N;
    cin >> N;
    vector<string> v(N);
    for(int i = 0; i < N; i++)
        cin >> v[i];
    sort(v.begin(), v.end(), cmp);
    string res;
    for(int i = 0; i < N; i++)
        res += v[i];
    while(res.length() != 0 && res[0] == 0)
        res.erase(res.begin());
    if(res.length() == 0) cout << 0;
    else cout << res;
    system("pause");
    return 0;
}

 

以上是关于PAT Advanced 1038 Recover the Smallest Number (30分)的主要内容,如果未能解决你的问题,请参考以下文章

PAT Advanced 1038 Recover the Smallest Number (30) [贪?算法]

PAT 1038. Recover the Smallest Number

PAT 1038 Recover the Smallest Number[dp][难]

PAT1038. Recover the Smallest Number

PAT Advanced Level 1038

[PAT] A1038 Recover the Smallest Number