PAT Advanced 1094 The Largest Generation (25) [BFS,DFS,树的遍历]
Posted houzm
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT Advanced 1094 The Largest Generation (25) [BFS,DFS,树的遍历]相关的知识,希望对你有一定的参考价值。
题目
A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.
Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.
Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4
题目分析
已知每个节点的所有子节点,求节点最多的层数max_num_h及对应层结点数max_num
解题思路
思路 01(最优)
邻接表存储树,dfs深度优先遍历树(当前节点所在层级用函数参数记录),int cndn[n]记录每层节点数,并更新max_num和max_num_h
思路 02
邻接表存储树,bfs深度优先遍历树(当前节点所在层级用int h[n]记录),int cndn[n]记录每层节点数,并更新max_num和max_num_h
易错点
题目理解错误,求的是节点最多的层(而不是节点最多的分支),求的是节点最多的层(而不是叶结点最多的层)
Code
Code 01(dfs 最优)
#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
vector<int> nds[101];//id从01开始
int cndn[101],max_num_h,max_num;
void dfs(int index, int h) {
cndn[h]++;
if(max_num<cndn[h]) {
max_num=cndn[h];
max_num_h=h;
}
if(nds[index].size()==0) return;
for(int i=0; i<nds[index].size(); i++)
dfs(nds[index][i],h+1);
}
int main(int argc,char * argv[]) {
int n,m,id,cn,cid;
scanf("%d %d",&n,&m);
for(int i=0; i<m; i++) {
scanf("%d %d", &id,&cn);
for(int j=0; j<cn; j++) {
scanf("%d", &cid);
nds[id].push_back(cid);
}
}
dfs(1,1);
printf("%d %d",max_num,max_num_h);
return 0;
}
Code 02(bfs)
#include <iostream>
#include <vector>
#include <queue>
using namespace std;
const int maxn=101;
vector<int> nds[maxn];
int cndn[maxn],max_num_h,max_num,h[maxn];
void bfs() {
queue<int> q;
q.push(1);
while(!q.empty()) {
int now = q.front();
q.pop();
cndn[h[now]]++;
if(max_num<cndn[h[now]]) {
max_num=cndn[h[now]];
max_num_h=h[now];
}
for(int i=0; i<nds[now].size(); i++) {
h[nds[now][i]]=h[now]+1;
q.push(nds[now][i]);
}
}
}
int main(int argc,char * argv[]) {
int n,m,id,cn,cid;
scanf("%d %d",&n,&m);
for(int i=0; i<m; i++) {
scanf("%d %d",&id,&cn);
for(int j=0; j<cn; j++) {
scanf("%d",&cid);
nds[id].push_back(cid);
}
}
h[1]=1;
bfs();
printf("%d %d",max_num,max_num_h);
return 0;
}
以上是关于PAT Advanced 1094 The Largest Generation (25) [BFS,DFS,树的遍历]的主要内容,如果未能解决你的问题,请参考以下文章
PAT Advanced 1094 The Largest Generation (25) [BFS,DFS,树的遍历]
PAT (Advanced Level) 1094. The Largest Generation (25)
PAT 1094 The Largest Generation[bfs][一般]
PAT 1094. The Largest Generation (层级遍历)