PAT甲级——1073 Scientific Notation (20分)

Posted mrcangye

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT甲级——1073 Scientific Notation (20分)相关的知识,希望对你有一定的参考价值。

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent‘s signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:
Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent‘s absolute value is no more than 9999.

Output Specification:
For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input 1:

+1.23400E-03

?
Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000

我的解法:

#include <iostream>
#include <string>
#include <cstring>
using namespace std;
int main() {
    string s;
    cin >> s;
    if(s[0] == '-')
        cout << "-";
    int n,i;
    for(i = 1; s[i] != 'E'; i++);
    string t = s.substr(1,i-1);
    n = stoi(s.substr(i+1));
    if(n < 0)
    {
        cout << "0.";
        for(int j = 0; j < abs(n)-1; j++)
            cout << "0";
        for(int j = 0; j < t.length(); j++)
        {
            if(t[j] != '.')
                cout << t[j];
        }
    }
    else{
        if(n >= t.length()-2)
        {
            for(int j = 0; j < t.length(); j++)
            {
                if( t[j] != '.')
                    cout << t[j];
            }
            for(int j=0 ;j < n-t.length()+2; j++)
            {
                cout << "0";
            }
        }
        else{
         for(int j = 0; j<n+2; j++)
         {
             if(t[j] != '.') 
                 cout << t[j];
         }
         cout << ".";
         for(int j= n+2; j < t.length(); j++)
            cout << t[j];
        }
    }
    return 0;
}

柳婼的解法:

#include <iostream>
using namespace std;
int main() {
 string s;
 cin >> s;
 int i = 0;
 while (s[i] != 'E') i++;
 string t = s.substr(1, i-1);
 int n = stoi(s.substr(i+1));
 if (s[0] == '-') cout << "-";
 if (n < 0) {
        cout << "0.";
         for (int j = 0; j < abs(n) - 1; j++) cout << '0';
         for (int j = 0; j < t.length(); j++)
         if (t[j] != '.') cout << t[j];
 } 
 else {
        cout << t[0];
         int cnt, j;
         for (j = 2, cnt = 0; j < t.length() && cnt < n; j++, cnt++) cout <<
t[j];
        if (j == t.length()) {
                for (int k = 0; k < n - cnt; k++) cout << '0';
        } 
        else {
                cout << '.';
                 for (int k = j; k < t.length(); k++) cout << t[k];
        }
 }
 return 0;
}

以上是关于PAT甲级——1073 Scientific Notation (20分)的主要内容,如果未能解决你的问题,请参考以下文章

PAT_A1073#Scientific Notation

PAT(A) 1073. Scientific Notation (20)

[PAT] 1073 Scientific Notation (20 分)Java

PAT 1073 Scientific Notation[字符串处理][科学记数法]

PAT (Advanced Level) 1073. Scientific Notation (20)

PAT甲题题解-1073. Scientific Notation (20)-字符串处理