1009 Product of Polynomials (25分) 多项式乘法

Posted -citywall123

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1009 Product of Polynomials (25分) 多项式乘法相关的知识,希望对你有一定的参考价值。

1009 Product of Polynomials (25分)

 

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N?1?? a?N?1???? N?2?? a?N?2???? ... N?K?? a?N?K????

where K is the number of nonzero terms in the polynomial, N?i?? and a?N?i???? (i=1,2,?,K) are the exponents and coefficients, respectively. It is given that 1K10, 0N?K??<?<N?2??<N?1??1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
 

Sample Output:

3 3 3.6 2 6.0 1 1.6

注意系数为0的情况

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
#include<stack>
#include<algorithm>
#include<map>
#include<string.h>
#include<string>
#define MAX 1000000
#define ll long long
using namespace std;
double a[10005],b[10005],c[10005];
double y;
int x;
int main()
{
    int k;
    cin>>k;
    for(int i=0;i<2006;i++)
        a[i]=b[i]=c[i]=0;
    for(int i=0;i<k;i++)
    {
        cin>>x>>y;
        a[x]=y;
    }
    cin>>k;
    for(int i=0;i<k;i++)
    {
        cin>>x>>y;
        b[x]=y;
    }
    for(int i=0;i<1005;i++)
    {
        for(int j=0;j<1005;j++)
            c[i+j]=c[i+j]+a[i]*b[j];//合并同类项
    }

    int cnt=0;
    for(int i=0;i<2005;i++)
    {
        if(c[i]!=0)//去除多项式系数为0的项
            cnt++;
    }
    cout<<cnt;
    for(int i=2005;i>=0;i--)
    {
        if(c[i]!=0)
            printf(" %d %.1lf",i,c[i] );
    }
    cout<<endl;
    return 0;
}

 

 

以上是关于1009 Product of Polynomials (25分) 多项式乘法的主要内容,如果未能解决你的问题,请参考以下文章

PAT1009:Product of Polynomials

1009 Product of Polynomials (25)(25 分)

1009 Product of Polynomials

1009 Product of Polynomials

1009 Product of Polynomials (25分) 多项式乘法

1009 Product of Polynomials (25 分)