Ice_cream’s world III//最小生成树kruskal

Posted w-j-c

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Ice_cream’s world III//最小生成树kruskal相关的知识,希望对你有一定的参考价值。

题目:

 

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2566    Accepted Submission(s): 904

Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 
Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 
Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 
Sample Input
2 1
0 1 10
 
4 0
 
Sample Output
10
impossible
 
思路:
 
代码:
#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;
const int size = 1e4 + 1;
struct edge
{
    int a, b, c;
};
struct edge edges[size];
int un[size];

int cmp(edge x, edge y)
{
    return x.c < y.c;
}

int find(int x)
{
    if(x == un[x])
        return x;
    return find(un[x]);
}

void Union(int x, int y)
{
    int c1 = find(x);
    int c2 = find(y);
    un[c1] = c2;
}

int main()
{
    int N, M;
    int S, T, C;
    while(cin >> N >> M)
    {
        for(int i = 0; i < N; i++)
            un[i] = i;

        for(int i = 0; i < M; i++)
        {
            cin >> edges[i].a >> edges[i].b >> edges[i].c;
        }
        sort(edges, edges+M, cmp);
        int count = N;
        int ans = 0;
        for(int i = 0; i < M; i++)
        {
            if(find(edges[i].a) == find(edges[i].b))
                continue;
            Union(edges[i].a, edges[i].b);
            count--;
            ans+=edges[i].c;
        }
        if(count != 1)
        {
            printf("impossible

");
            continue;
        }
        printf("%d

", ans);
    }
    return 0;
}

 



以上是关于Ice_cream’s world III//最小生成树kruskal的主要内容,如果未能解决你的问题,请参考以下文章

HDU - 2121 Ice_cream’s world II 无根最小树形图

HDU2121 Ice_cream’s world II

hdu 2121 Ice_cream’s world II

HDU - 2121 Ice_cream’s world II

hdu 2121 Ice_cream’s world II

有向图最小生成树无定根 并要求求出根的位置