hdu 5187 基于快速幂的快速乘法

Posted vainglory

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 5187 基于快速幂的快速乘法相关的知识,希望对你有一定的参考价值。

zhx‘s contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3568    Accepted Submission(s): 1146


Problem Description
As one of the most powerful brushes, zhx is required to give his juniors n problems.
zhx thinks the ith problem‘s difficulty is i. He wants to arrange these problems in a beautiful way.
zhx defines a sequence {ai} beautiful if there is an i that matches two rules below:
1: a1..ai are monotone decreasing or monotone increasing.
2: ai..an are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems‘ difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module p.
 

 

Input
Multiply test cases(less than 1000). Seek EOF as the end of the file.
For each case, there are two integers n and p separated by a space in a line. (1n,p1018)
 

 

Output
For each test case, output a single line indicating the answer.
 

 

Sample Input
2 233 3 5
 

 

Sample Output
2 1
Hint
In the first case, both sequence {1, 2} and {2, 1} are legal. In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1
 

 

Source
 

 

Recommend
hujie   |   We have carefully selected several similar problems for you:  6297 6296 6295 6294 6293 
 
 
快速乘法指的是在 a*b会爆ll 的情况下所进行的操作>>从而不必应用java大数来操作
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll n,p;
ll multi(ll a,ll b){
	ll res=0,tmp=a;
	while(b){
		if(b&1) (res+=tmp)%=p;
		b/=2;
		(tmp+=tmp)%=p;
	}
	return res;
}
ll pow_(ll a,ll b){
	ll res=1,tmp=a;
	while(b){
		if(b&1) res=multi(res,tmp);
		tmp=multi(tmp,tmp);
		b/=2;
	} 
	return res;
}
int main(){
	while(cin>>n>>p){
		ll ans=pow_(2,n);
		ans-=2;
		ans=(ans%p+p)%p;
		cout<<ans<<endl;
	}
	return 0;
} 

  












以上是关于hdu 5187 基于快速幂的快速乘法的主要内容,如果未能解决你的问题,请参考以下文章

人生第一个快速幂的题(HDU - 1097--A hard puzzle )

51Nod 1013 3的幂的和 快速幂 | 乘法逆元 | 递归求和公式

51 Nod 1013 3的幂的和 矩阵链乘法||逆元+快速幂

快速幂的思想

快速乘法

矩阵快速幂的一份小结