Cow Exhibition (01背包)

Posted zdragon1104

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Cow Exhibition (01背包)相关的知识,希望对你有一定的参考价值。

"Fat and docile, big and dumb, they look so stupid, they aren‘t much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si‘s and, likewise, the total funness TF of the group is the sum of the Fi‘s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 
题目大意:
给定n头牛的TS值和TF值,求最大的TS+TF值,前提是TS的和与TF的和不为负数。
由于有负数,所以整体移动1e5,即1e5相当于0。
#include <iostream>
#include <cstring>
using namespace std;
const int INF=0x3f3f3f3f;
const int mid=1e5;
int dp[200005],s[105],f[105];
int main()
{
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)
        cin>>s[i]>>f[i];
    fill(dp,dp+200005,-INF);
    dp[mid]=0;
    for(int i=1;i<=n;i++)
    {
        if(s[i]>0)
        {
            for(int j=200004;j>=s[i];j--)
                dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
        }
        else
        {
            for(int j=0;j-s[i]<200005;j++) ///j-s[i]>j因此递增
                dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
        }
    }
    int ans=0;
    for(int i=mid;i<200005;i++)
        if(dp[i]>=0)
            ans=max(ans,dp[i]+i-mid);
    cout<<ans<<
;
    return 0;
}

 















以上是关于Cow Exhibition (01背包)的主要内容,如果未能解决你的问题,请参考以下文章

poj2184Cow Exhibition01背包 负数

poj2184 Cow Exhibition(p-01背包的灵活运用)

台州 OJ 5072 Cow Exhibition 01背包

Cow Exhibition POJ 2184(01背包dp)

POJ - 2184 Cow Exhibition

USACO 2003 Fall Orange Cow Exhibition /// 负数01背包 oj22829