51nod 3059STL最近的一对
Posted SSL_ZZL
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了51nod 3059STL最近的一对相关的知识,希望对你有一定的参考价值。
最近的一对
题目
给出包含n个元素的数组a,求a中距离最近的一对 i,j,满足i < j 且 a[i] == a[j]。如果同时存在多对,输出最小的 i 对应的a[i]。
例如:10个数
19,13,11,19,11,5,6,3,4,3
满足存在a[i]=a[j]的数字包括:19,11,3。其中11,3这两对的距离更近,在距离相同的情况下,11的下标更靠前。如果不存在相同的数字,输出 “No”
输入
第一行:1个数n表示数组的长度(2 <= n <= 100000)。
第2至n+1行:每行1个数,对应数组的元素(1<= a[i] <= 10^9)
输出
输出符合条件的最小的a[i]。
数据范围
2 <= n <= 100000
1<= a[i] <= 10^9
输入样例
10
19
13
11
19
11
5
6
3
4
3
输出样例
11
样例解释
满足存在a[i]=a[j]的数字包括:19,11,3。
其中11,3这两对的距离更近,在距离相同的情况下,11的下标更靠前。
解题思路
用了map
用map记录位置,所以可以用map得到当前数上一次出现的位置,这个是能得到的最小的位置
比如1 2 3 2 5 2
第三个2向前最近的一定第二个2, 第一个2与第三个2之间的位置更远
没用map,用了pair
把 a 从小到大排序,这样相同的数都放在一起了
排序时把原位置也记录下来,就可以暴力配对
排序时数值为第一关键字,原位置是第二关键字,所以相同数中相邻两个数的位置差是最小的
Code
用了map
#include <bits/stdc++.h>
using namespace std;
int n, ansx, ansy, ans, x;
map<int, int> M;
int main()
scanf("%d", &n);
ansx = n + 1, ansy = 2 * (n + 1);
for(int i = 1; i <= n; i ++)
scanf("%d", &x);
map<int, int>::iterator it;
it = M.find(x);
if(it != M.end())
if(i - it -> second < ansy - ansx)
ansx = it -> second, ansy = i, ans = x;
else if(i - it -> second == ansy - ansx && it -> second < ansx)
ansx = it -> second, ansy = i, ans = x;
M[x] = i;
if(ansx == n + 1) printf("No");
else printf("%d", ans);
没用map,用了pair
#include <bits/stdc++.h>
#define N 100000
using namespace std;
int n, ansx, ansy, ans;
pair<int, int> a[N + 200];
int main()
scanf("%d", &n);
for(int i = 1; i <= n; i ++)
scanf("%d", &a[i].first);
a[i].second = i;
sort(a + 1, a + 1 + n);
ansy = 2 * (n + 1), ansx = n + 1;
for(int i = 1; i < n; i ++)
if(a[i].first != a[i + 1].first) continue;
if(a[i + 1].second - a[i].second < ansy - ansx)
ansx = a[i].second, ansy = a[i + 1].second, ans = a[i].first;
else if(a[i + 1].second - a[i].second == ansy - ansx && a[i].second < ansx)
ansx = a[i].second, ansy = a[i + 1].second, ans = a[i].first;
if(ansx == n + 1)printf("NO");
else printf("%d", ans);
以上是关于51nod 3059STL最近的一对的主要内容,如果未能解决你的问题,请参考以下文章