POJ.2559Largest Rectangle in a Histogram(单调栈)

Posted SSL_LKJ

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ.2559Largest Rectangle in a Histogram(单调栈)相关的知识,希望对你有一定的参考价值。

Largest Rectangle in a Histogram

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,…,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Hint

Huge input, scanf is recommended.

输入样例

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

输出样例

8
4000

解题思路

单调递增栈模板

AC代码

#include<iostream>
#include<cstdio>
using namespace std;
long long n,o,s,tail,a[100005];
struct node

	long long x,y;
f[100005];
int main()

	scanf("%lld",&n);
    while(n!=0)
    
     	for(int i=1;i<=n;i++)scanf("%lld",&a[i]);
     	s=tail=0;
     	for(int i=1;i<=n;i++)
     	
     	 	o=0;
     	 	while(f[tail-1].x>=a[i]&&tail>0) //单调栈
     	 	
     	 	   s=max(s,f[tail-1].x*(f[tail-1].y+o));
     	 	   o+=f[tail-1].y; 
     	 	   tail--;
     	 	
     	 	f[tail].x=a[i];
     	 	f[tail].y=o+1;
     	 	tail++;
     	
     	o=0;
     	while(tail>0)
     	
     	    s=max(s,f[tail-1].x*(f[tail-1].y+o));
     	 	o+=f[tail-1].y;
     	 	tail--;
     	
     	printf("%lld\\n",s);
     	scanf("%lld",&n);
    

谢谢

以上是关于POJ.2559Largest Rectangle in a Histogram(单调栈)的主要内容,如果未能解决你的问题,请参考以下文章

POJ2559 Largest Rectangle in a Histogram

(单调栈)poj-2559 Largest Rectangle in a Histogram

POJ.2559Largest Rectangle in a Histogram(单调栈)

POJ.2559Largest Rectangle in a Histogram(单调栈)

POJ 2559 Largest Rectangle in a Histogram(单调栈)

POJ 2559 Largest Rectangle in a Histogram (栈的运用)