Bone Collector???01?????????

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Bone Collector???01?????????相关的知识,希望对你有一定的参考价值。

?????????for   eof   Collector   algorithm   ring   cow   different   name   AC   

Many years ago , in Teddy???s hometown there was a man who was called ???Bone Collector???. This man like to collect varies of bones , such as dog???s , cow???s , also he went to the grave ??? 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone???s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 
??????????????????

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14
???????????????
??????n???v????????????n?????????????????????v?????????????????????n???????????????n?????????????????????????????????n???????????????n?????????????????????
01????????????
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int w[1005],v[1005],dp[1005];
int n,m;
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        memset(dp,0,sizeof dp);
        cin>>n>>m;
        for(int i=1;i<=n;i++)
            cin>>v[i];
        for(int i=1;i<=n;i++)
            cin>>w[i];
        for(int i=1;i<=n;i++)
            for(int j=m;j>=w[i];j--)
                dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
        cout<<dp[m]<<???
???;
    }
    return 0;
}

 

 







以上是关于Bone Collector???01?????????的主要内容,如果未能解决你的问题,请参考以下文章

hdu2602 Bone Collector 01背包

HDU 2602Bone Collector(裸的01背包)

HDU 2602 Bone Collector(01背包)

Bone Collector II(01背包kth)

01背包HDU 2602 Bone Collector (模板题)

HDU 2602 Bone Collector (01背包问题)