( 大数 startsWith substring) Exponentiation hdu1063

Posted weixu-liu

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了( 大数 startsWith substring) Exponentiation hdu1063相关的知识,希望对你有一定的参考价值。

Exponentiation

Time Limit: 2000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10319    Accepted Submission(s): 3027

 

 

Problem Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

 

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

 

 

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

 

 

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don‘t print the decimal point if the result is an integer.

 

 

Sample Input

95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12

 

 

Sample Output

548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201

 

利用BigDecimal

 

import java.math.BigDecimal;
import java.math.BigInteger;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        BigDecimal a;
        while(in.hasNextBigDecimal()) {
            a=in.nextBigDecimal();
            int  b=in.nextInt();
            String s=a.pow(b).stripTrailingZeros().toPlainString();   //最后成了字符串。
            if(s.startsWith("0")) {
                s=s.substring(1);
            }   //startsWith()是判断字符串是否以某个字符串开头,若是,返回true,String.substring(int start)参数:start:要截取位置的索引。返回:从start开始到结束的字符串。
            System.out.println(s);
        }
    }
}

 

以上是关于( 大数 startsWith substring) Exponentiation hdu1063的主要内容,如果未能解决你的问题,请参考以下文章

C# 为什么高手喜欢用StartsWith而不是Substring进行字符串匹配?

实现php的startsWith和endsWith

两大数相乘 -- javascript 实现

scala 模式匹配以删除某些情况

subString的使用小Demo

第六周