(compareTo) How Many Fibs hdu1316 && ZOJ1962

Posted weixu-liu

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了(compareTo) How Many Fibs hdu1316 && ZOJ1962相关的知识,希望对你有一定的参考价值。

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7007    Accepted Submission(s): 2761

 

 

Problem Description

Recall the definition of the Fibonacci numbers:

f1 := 1

f2 := 2

fn := fn-1 + fn-2 (n >= 3)

 

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].

 

Input

The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.

 

Output

For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.

 

Sample Input

10 100

1234567890 9876543210

0 0

 

Sample Output

5

4

用Java,然后利用compareTo来判断大小。

 

 

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        BigInteger a,b;
        while(in.hasNextBigInteger()) {
            a=in.nextBigInteger();
            b=in.nextBigInteger();
            if(a.equals(BigInteger.valueOf(0))&&b.equals(BigInteger.valueOf(0)))
                break;                 //也可以用compareTo。
            System.out.println(Fib(a,b));
        }
    }
     public static int Fib(BigInteger a,BigInteger b)  
        {  
            int sum = 0;  
            BigInteger f = new BigInteger("1");  
            BigInteger s = new BigInteger("2");  
            BigInteger tmp;  
            while(true)  
            {  
                if(f.compareTo(b)>0)  
                    break;  
                if(f.compareTo(a) >= 0)  
                    sum++;  
                tmp = f;                      //可以用迭代的方法求斐波那契数列。
                f = s;  
                s = s.add(tmp);  
            }  
            return sum;  
        }  
}

 

以上是关于(compareTo) How Many Fibs hdu1316 && ZOJ1962的主要内容,如果未能解决你的问题,请参考以下文章

POJ 2413 How many Fibs?#二分+大数加法

UVA - 10061 How many zero&#39;s and how many digits ?

hdu 1316 How Many Fibs?

P - How many

HDOJ 1316 How Many Fibs?

LightOJ - 1140 How Many Zeroes?