日期类问题

Posted womendouyiyang

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了日期类问题相关的知识,希望对你有一定的参考价值。

题目描述:

  有两个日期,求两个日期之间的天数,如果两个日期是连续的我们规定他们之间的天数是两天

样例输入:

20110412

20110422

样例输出:

11

#include<stdio.h>
#define isleap(x) x%100!=0&&x%4==0||x%400==0
int dayofmonth[13][2]={
    0,0,
    31,31,
    28,29,
    31,31,
    30,30,
    31,31,
    30,30,
    31,31,
    31,31,
    30,30,
    31,31,
    30,30,
    31,31,
};

struct Date{
    int year;
    int month;
    int day;
    void nextday()
    {
        day++;
        if(day>dayofmonth[month][isleap(year)])
        {
            day=1;
            month++;
            if(month>12)
            {
                month=1;
                year++;
            }
        }
    }
};

int buf[5001][13][32];
int abs(int x)
{
    return x>0?x:-x;
}

int main()
{
    Date tmp;
    int count=0;
    tmp.day=1;
    tmp.month=1;
    tmp.year=0;
    while(tmp.year!=5001)
    {
        buf[tmp.year][tmp.month][tmp.day]=count;
        tmp.nextday();
        count++;
    }
    int y,m,d;
    int y1,m1,d1;
    while(scanf("%4d%2d%2d",&y,&m,&d)!=EOF)
    {
        scanf("%4d%2d%2d",&y1,&m1,&d1);
        printf("%d",abs(buf[y][m][d]-buf[y1][m1][d1])+1);
    }
    return 0;
}

 

以上是关于日期类问题的主要内容,如果未能解决你的问题,请参考以下文章

常用python日期日志获取内容循环的代码片段

JS代码片段:一个日期离现在多久了

sql 日期转换代码片段 - Dato,120,konvertere

日期选择器对话框在片段中不起作用[关闭]

Android Navigation java.language.IllegalStateException 片段类未设置

如何从我的 DatePicker 片段中传输格式化的日期字符串?