PTA (Advanced Level)1005.Spell It Right
Posted martinlwx
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PTA (Advanced Level)1005.Spell It Right相关的知识,希望对你有一定的参考价值。
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.
Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10100).
Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.
Sample Input:
12345
Sample Output:
one five
思路
- 每读入一个字符就加到
sum
里,最后转为字符串,逐字符输出对应的英文单词就好了
代码
#include<bits/stdc++.h>
using namespace std;
char q[10][10] = {"zero", "one", "two", "three", "four", "five",
"six", "seven", "eight", "nine"};
int main()
{
char ch;
int ans = 0;
while(cin>>ch)
{
ans += ch - '0';
}
string s = to_string(ans);
//cout << ans << endl;
for(int i=0;i<s.size();i++)
{
if(i != s.size() - 1)
cout << q[s[i]-'0'] << " ";
else cout << q[s[i]-'0'];
}
return 0;
}
引用
https://pintia.cn/problem-sets/994805342720868352/problems/994805519074574336
以上是关于PTA (Advanced Level)1005.Spell It Right的主要内容,如果未能解决你的问题,请参考以下文章
PTA(Advanced Level)1015.Reversible Primes
PTA(Advanced Level)1025.PAT Ranking
PTA (Advanced Level)1022 Digital Library
PTA(Advanced Level)1059.Prime Factors