1001 A+B Format

Posted ruruozhenhao

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1001 A+B Format相关的知识,希望对你有一定的参考价值。

1001 A+B Format (20分)
 

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 

题解:这里所说的每三个数字中间添加一个‘,’是指从右边的第一个数字开始数,每三个数字添加一个‘,’。有时间的话还是要把那本《C++ prime plus》再看一遍,很多C++的基础语法都忘了=_=

 

#include<iostream>
using namespace std;

int main() {
    int a, b;

    cin >> a >> b;

    string s = to_string(a+b);
    int len = s.length();

    for (int i = 0; i < len; ++i) {
        cout << s[i];
        
        if (s[i] == ‘-‘) continue;

        if ((i + 1) % 3 == len % 3 && i != len - 1)
            cout << ‘,‘;
    }

    cout << endl;
    return 0;
}

  

以上是关于1001 A+B Format的主要内容,如果未能解决你的问题,请参考以下文章

PAT甲级 1001. A+B Format (20)

1001A+B Format

1001 A+B Format

PAT甲级(1001:A+B Format)

1001 A+B Format

PAT 1001 A+B Format