PAT Advanced level 1002 A+B for Polynomials

Posted wypx

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT Advanced level 1002 A+B for Polynomials相关的知识,希望对你有一定的参考价值。

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N?1?? a?N?1???? N?2?? a?N?2???? ... N?K?? a?N?K????

where K is the number of nonzero terms in the polynomial, N?i?? and a?N?i???? (,) are the exponents and coefficients, respectively. It is given that 1,0.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
 

Sample Output:

3 2 1.5 1 2.9 0 3.2




模拟多项式加法
模拟就行了……
想到什么再补吧(

#include<iostream>
#include<cstdio>
#include<algorithm>
double a[1001];
using namespace std;

int main(){
    int k1;scanf("%d",&k1);
    for(int i=1;i<=k1;++i){
        int ni;double ai;
        scanf("%d%lf",&ni,&ai);
        a[ni]+=ai; 
    }
    int k2;scanf("%d",&k2);
    for(int i=1;i<=k2;++i){
        int ni;double ai;
        scanf("%d%lf",&ni,&ai);
        a[ni]+=ai; 
    }
    int cnt=0;
    for(int i=1000;i>=0;--i){
        if(a[i])++cnt;
    }
    printf("%d",cnt);
    for(int i=1000;i>=0;--i){
        if(a[i])printf(" %d %.1f",i,a[i]);
    }
    return 0;
} 

以上是关于PAT Advanced level 1002 A+B for Polynomials的主要内容,如果未能解决你的问题,请参考以下文章

PAT (Advanced Level) 1025. PAT Ranking (25)

PAT Advanced 1002 A+B for Polynomials (25分)

浙大 PAT Advanced level 1026. Table Tennis (30)

1093. Count PAT's (25)计数——PAT (Advanced Level) Practise

PAT (Advanced Level) 1029. Median (25)

PAT (Advanced Level) 1032. Sharing (25)