I - 二分 HYSBZ - 1734

Posted studyshare777

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了I - 二分 HYSBZ - 1734相关的知识,希望对你有一定的参考价值。

I - 二分

HYSBZ - 1734

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). His C (2 <= C <= N) cows don‘t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

农夫 John 建造了一座很长的畜栏,它包括NN (2 <= N <= 100,000)个隔间,这些小隔间依次编号为x1,...,xN (0 <= xi <= 1,000,000,000). 但是,John的C (2 <= C <= N)头牛们并不喜欢这种布局,而且几头牛放在一个隔间里,他们就要发生争斗。为了不让牛互相伤害。John决定自己给牛分配隔间,使任意两头牛之间的最小距离尽可能的大,那么,这个最大的最小距离是什么呢

Input

* Line 1: Two space-separated integers: N and C * Lines 2..N+1: Line i+1 contains an integer stall location, xi

第一行:空格分隔的两个整数N和C

第二行---第N+1行:i+1行指出了xi的位置

 

Output

* Line 1: One integer: the largest minimum distance

第一行:一个整数,最大的最小值

 

Sample Input

5 3 1 2 8 4 9

 

Sample Output

3 把牛放在1,4,8这样最小距离是3

 

题目描述:

对于2头牛间最小距离,找到他的最大值。

分析:

对每一个可能的答案,我们用一个judge函数判断它是否符合题目。

如对于答案距离分别为1,2,3,4,5,6.....

如题目,3是最大的满足题目的数,我们要找到它。对于3前面的,因为距离比较小,一定可以把牛安排满,3后面的都不行。

答案有一种单调性,(前面错后面对),对答案进行二分来减少找答案的时间。

二分一般是左闭合,所以l=mid时要+1。

代码:

#include<iostream> 
#include<stdio.h>
#include<algorithm>
#define Min(x,y) x<y?x:y;
using namespace std;
int n,c;
int a[100006];
int judge(int x)
{
    int cow=1;
    int k=0;
    for(int i=0;i<n;i++)
    {
        if(a[i]>=a[k]+x)
        {
            k=i;
            cow++;
        }
    }
    if(cow>=c) return 1;
    else return 0;
}
int main()
{
    scanf("%d %d",&n,&c);
    for(int i=0;i<n;i++)
    {
        cin>>a[i];
    }
    sort(a,a+n);
    int l=0;
    int r=a[n-1];
    int mid;
    while(l<r)
    {
        mid=(l+r)/2;
        if(judge(mid))
        {
            l=mid+1;
        }
        else
        {
            r=mid;
        }
    }
    cout<<r-1<<
;
    return 0;
}
 

以上是关于I - 二分 HYSBZ - 1734的主要内容,如果未能解决你的问题,请参考以下文章

任务安排 HYSBZ - 2726 (斜率优化 + 二分)

HYSBZ 2440 完全平方数(莫比乌斯反演)

cdq分治整体二分bzoj 3110: [Zjoi2013] HYSBZ - 3110 K大数查询

LeetCode每日一题(1734. 解码异或后的排列)

1734. 解码异或后的排列(思维)

poj[1734]