PAT Advanced 1009 Product of Polynomials (25分)

Posted littlepage

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT Advanced 1009 Product of Polynomials (25分)相关的知识,希望对你有一定的参考价值。

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

N?1?? a?N?1???? N?2?? a?N?2???? ... N?K?? a?N?K????

where K is the number of nonzero terms in the polynomial, N?i?? and a?N?i???? (,) are the exponents and coefficients, respectively. It is given that 1, 0.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
 

Sample Output:

3 3 3.6 2 6.0 1 1.6

多项式相乘,我们需要注意去使用map进行存储,去除结果为0的,然后输出即可

#include <iostream>
#include <vector>
#include <map>
using namespace std;
struct poly{
    double coeff;
    int expo;
};
int main()
{
    int M;poly tmp;
    vector<poly> poly1,poly2;
    /**input*/
    cin>>M;
    while(M--){
        cin>>tmp.expo>>tmp.coeff;
        poly1.push_back(tmp);
    }
    cin>>M;
    while(M--){
        cin>>tmp.expo>>tmp.coeff;
        poly2.push_back(tmp);
    }
    map<int,double,greater<int>> m;
    /**计算*/
    for(int i=0;i<poly1.size();i++)
        for(int j=0;j<poly2.size();j++)
            m[poly1[i].expo+poly2[j].expo]+=poly1[i].coeff*poly2[j].coeff;
    /**去0*/
    for(auto it=m.begin();it!=m.end();it++)
        if(it->second==0) m.erase(it);
    /**输出*/
    cout<<m.size();
    for(auto it=m.begin();it!=m.end();it++)
        printf(" %d %.1f",it->first,it->second);
    system("pause");
    return 0;
}

以上是关于PAT Advanced 1009 Product of Polynomials (25分)的主要内容,如果未能解决你的问题,请参考以下文章

PAT1009:Product of Polynomials

[PTA] PAT(A) 1009 Product of Polynomials (25 分)

PAT甲级——A1009 Product of Polynomials

PAT A1009 Product of Polynomials (25 分)

PAT-A 1009. Product of Polynomials

PAT 甲级测试题目 -- 1009 Product of Polynomials