PAT Advanced 1031 Hello World for U (20分)

Posted littlepage

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了PAT Advanced 1031 Hello World for U (20分)相关的知识,希望对你有一定的参考价值。

Given any string of N (≥) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo
 

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n?1?? characters, then left to right along the bottom line with n?2?? characters, and finally bottom-up along the vertical line with n?3?? characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n?1??=n?3??=max { k | kn?2?? for all 3 } with n?1??+n?2??+n?3??2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!
 

Sample Output:

h   !
e   d
l   l
lowor

 

这道题目考察了格式化字串,我们需要先补2个位置,除以三,进行计算两边的数量,最后再计算中间的

#include <iostream>
using namespace std;
int main() {
    string str;
    getline(cin, str);
    int row, N = str.length(), recol;
    row = (N + 2) / 3 ;
    recol = (N + 2) / 3 + (N + 2) % 3 - 2;
    for(int i = 0; i < row; i++){
        cout << str[i];
        for(int j = 0; j < recol; j++)
            if(i != row - 1) cout << " ";
            else cout << str[j + row];
        cout << str[N - i -1] << endl;
    }
    return 0;
}

以上是关于PAT Advanced 1031 Hello World for U (20分)的主要内容,如果未能解决你的问题,请参考以下文章

PAT 甲级 1031 Hello World for U

PAT甲级——A1031 Hello World for U

PAT甲级1031 Hello World for U (20 分)

PAT甲级1031

PAT乙级1031

1104. Sum of Number Segments (20)数学题——PAT (Advanced Level) Practise