1058 A+B in Hogwarts (20分)

Posted f4lc0n

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1058 A+B in Hogwarts (20分)相关的知识,希望对你有一定的参考价值。

1058 A+B in Hogwarts (20分)

题目:

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it‘s easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27 

### Sample Output:

14.1.28

题意:

17 Sickle = 1 Galleon ; 29 Knuts = 1 Sickle

例子:

3.2.1 + 10.16.27 = 13.18.28 = 14.1.28

题解:

#include <cstdio>
int main() {
    int ag,as,ak,bg,bs,bk,g,s,k;
    scanf("%d.%d.%d %d.%d.%d",&ag,&as,&ak,&bg,&bs,&bk);
    g = ag + bg;
    s = as + bs;
    k = ak + bk;
    if(k >= 29) s += (k / 29), k %= 29;
    if(s >= 17) g += (s / 17), s %= 17;
    printf("%d.%d.%d",g,s,k);
    return 0;
}

以上是关于1058 A+B in Hogwarts (20分)的主要内容,如果未能解决你的问题,请参考以下文章

pat 1058 A+B in Hogwarts(20 分)

1058 A+B in Hogwarts (20 分)

1058 A+B in Hogwarts (20分)(水)

PAT 甲级 1058 A+B in Hogwarts (20 分) (简单题)

1058 A+B in Hogwarts (20 分)难度: 简单 / 知识点: 模拟

PAT-进制转换-A1058 A+B in Hogwarts (20分)