hdu1062 text reverse

Posted sos3210

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu1062 text reverse相关的知识,希望对你有一定的参考价值。

 咳咳,这个是为了赶量

需要注意的就是输入方式,别的也没什么难点

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

 

Output
For each test case, you should output the text which is processed.
 

 

Sample Input
3
olleh !dlrow
m‘I morf .udh
I ekil .mca
 

 

Sample Output
hello world!
I‘m from hdu.
I like acm.
这是题意
接下来放代码

#include <iostream>
#include <cstdio>
#include <stack>
using namespace std;

int main(){
int n;
cin >> n;
getchar();
while(n--){
stack<char>cst;
while(1){
int ch=getchar();
if(ch==‘ ‘||ch==‘ ‘){
while(!cst.empty()){
cout << cst.top();
cst.pop();
}
if(ch==‘ ‘)cout << ‘ ‘;
else break;
}
else cst.push(ch);
}
cout << endl;
}
return 0;
}

OK

以上是关于hdu1062 text reverse的主要内容,如果未能解决你的问题,请参考以下文章

hdu1062 text reverse

Hdu 1062 Text Reverse

HDOJ/HDU 1062 Text Reverse(字符串翻转~)

题解报告:hdu 1062 Text Reverse

HDU 1062 Text Reverse

J - Text Reverse HDU - 1062