stack的使用-Hdu 1062

Posted jingshixin

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了stack的使用-Hdu 1062相关的知识,希望对你有一定的参考价值。

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51495    Accepted Submission(s): 19692


Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

 

Output
For each test case, you should output the text which is processed.
 

 

Sample Input
3 olleh !dlrow m‘I morf .udh I ekil .mca
 

 

Sample Output
hello world! I‘m from hdu. I like acm.
 
首先这个题就是简单的字符串反转,注意点是遇到空格怎么处理,用STL中的栈来模拟
代码:
#include <bits/stdc++.h>

using namespace std;

int main()
{
    int n;
    char ch;
    cin>>n;
    getchar();
    while(n--){
        stack<char>s;
        while(true){
            ch = getchar();
            if(ch== ||ch==
||ch==EOF){
                while(!s.empty()){
                    cout<<s.top();
                    s.pop();
                } 
                if(ch==
||ch==EOF)
                    break;
                cout<<" ";
            }
            else
                s.push(ch);
        }
        cout<<endl;
    }
    return 0;
}

 

以上是关于stack的使用-Hdu 1062的主要内容,如果未能解决你的问题,请参考以下文章

[hdu 1062] Text Reverse | STL-stack

J - Text Reverse HDU - 1062

题解报告:hdu 1062 Text Reverse

HDU 1062 Text Reverse

杭电 -- 1062 解法一

HDU 1062 Text Reverse