A+B 8
Posted heroin1
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了A+B 8相关的知识,希望对你有一定的参考价值。
你的任务是计算多个数的和。
Input第一行输入一个整数 N。接下来的 N 行,每行都以一个整数 M 开头,接下来的 M 个数位于同一行。
Output对于输入的每组数据,你需要在一行内输出它们的和,且需要注意的是每组输出之间都要有一个空行。
Sample Input
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
Sample Output
10 15 6
#include<iostream>
using namespace std;
int main(void) {
int a,i,c=0,d,j,h=0;
int b[100];
cin>>d;
for(j=0; j<d; j++) {
cin>>a;
if(a==0) {
break;
} else
for(i=0; i<a; i++) {
cin>>b[i];
}
for(i=0; i<a; i++) {
c+=b[i];
}
cout<<c<<endl;
h++;
if(h!=d)
cout<<endl;
c=0;
}
}
之前格式错误好几次,需要注意的就是最后一行的输出没有换行符。
以上是关于A+B 8的主要内容,如果未能解决你的问题,请参考以下文章
[Codeforces Round #522 (Div. 2, based on Technocup 2019 Elimination Round 3)][C. Playing Piano](代码片段