HDoj 1002 A + B Problem II

Posted wzmm

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDoj 1002 A + B Problem II相关的知识,希望对你有一定的参考价值。


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author
Ignatius.L

Recommend
We have carefully selected several similar problems for you: 1004 1003 1008 1005 1089

#include<iostream>
#include<stdio.h>
#include<string>
using namespace std;
int main()
{
    string s1="";
    string s2="";
    string s3="";
    int n;
    int length=0;
    cin>>n; 
    int num=1; 
    while(n--)
    {
        cin>>s1>>s2;
        string s4=s2;
        string s5=s1;
        if(s1.length()>s2.length())
        {
            length=s1.length();
        }
        else
        {
            s3=s1;
            s1=s2;
            s2=s3;
            length=s1.length();
        }
        s3=string(s1.length()-s2.length(),0);
        s2=s3+s2;
        //cout<<s1<<s2; 
        string temp="0";
        int t=0;
        for(int i=length-1;i>=0;i--)
        {
            t=((s1[i]-48)+(s2[i]-48)+(temp[0]-48));
            s1[i]=t%10+48;
            if(t>=10)
            temp[0]=1;
            else
            temp[0]=0;
            
        } 
        cout<<"Case"<<" "<<num++<<":"<<endl;
        if(t>=10)
        cout<<s5<<" + "<<s4+" = "<<"1"<<s1<<endl;
        else
        cout<<s5<<" + "<<s4+" = "<<s1<<endl; 
        if(n!=0)
        cout<<endl; 
        
        
    }
    
    return 0;
}
//注意!!!!!!!!!!!!!!!!!!!!!!!!!!最后一行不要输出空行

 

以上是关于HDoj 1002 A + B Problem II的主要内容,如果未能解决你的问题,请参考以下文章

HDOJ 1002

HDOJ3828 A + B problem

HDOJ(HDU)1000A + B Problem Java题解

Hdoj 1002

HDU 1002 A - A + B Problem II (大数问题)

A + B Problem II(杭电1002)