Palindrome

Posted vetsama

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Palindrome相关的知识,希望对你有一定的参考价值。

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

依旧是lcs,所求的值等于n-最长公共子序列,输入数据有多组

这个题如果直接做会mle,所以用滚动数组优化一下,因为lcs只和上一行有关,所以每次dp完一行就把它滚动到到上一行,行数需求只有2

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;

int max(int a, int b) {
    return a > b ? a : b;
}

int main()
{
    int n;

    while (cin >> n) {
        int map[2][5001] = { 0 };
        char a[5001] = { 0 };
        char b[5001] = { 0 };
        getchar();

        for (int i = 1; i <= n; i++) {
            a[i] = getchar();
            b[n - i + 1] = a[i];
        }

        for (int i = 1; i <= n; i++) {
            for (int j = 1; j <= n; j++) {
                if (a[i] == b[j]) {
                    map[1][j] = map[0][j - 1] + 1;
                }
                else {
                    map[1][j] = max(map[0][j], map[1][j - 1]);
                }
            }
            for (int j = 1; j <= n; j++) {
                map[0][j] = map[1][j];
            }

        }
        cout << n - map[1][n] << endl;
    }

    return 0;
}

 

以上是关于Palindrome的主要内容,如果未能解决你的问题,请参考以下文章

leetcode9. Palindrome Number

009.Palindrome Number

LeetCode:Palindrome Number

266. Palindrome Permutation

poj3974 Palindrome

codeforces 1045I Palindrome Pairs stl+构造